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FileMaker	
  Level	
  3	
  Cheatsheet	
  

Shortcuts	
  
Shortcut	
   What	
  It	
  Does	
  
CTRL + B or ⌘ + B Browse	
  Mode	
  (For	
  editing,	
  browsing	
  records)	
  
CTRL + F or ⌘ + F Find	
  Mode	
  (for	
  searching	
  records)	
  
CTRL + L or ⌘ + L Layout	
  Mode	
  (For	
  designing	
  the	
  look	
  and	
  feel	
  of	
  your	
  database	
  or	
  reports.)	
  
CTRL + U or ⌘ + U Preview	
  Mode	
  (Print	
  Preview,	
  PDF	
  Export	
  and	
  Excel	
  Export)	
  
CTRL + R or ⌘ + R Modify	
  the	
  last	
  find	
  
CTRL + N or ⌘ + N New	
  Record	
  
CTRL + D or ⌘ + D Duplicate	
  Record	
  
CTRL + E or ⌘ + E Delete	
  Record	
  
CTRL + J or ⌘ + J Show	
  All	
  Records	
  
CTRL + S or ⌘ + S Sort	
  Records	
  
CTRL + O or ⌘ + O Open	
  a	
  New	
  Database	
  
CTRL + W or ⌘ + W Close	
  a	
  Database	
  
CTRL + Z or ⌘ + Z Undo	
  
CTRL + A or ⌘ + A Select	
  All	
  
CTRL + M or ⌘ + M Insert	
  a	
  Merge	
  Field	
  
CTRL + T or ⌘ + T Omit	
  a	
  Record	
  
CTRL + I or ⌘ + I Show/Hide	
  Inspector	
  in	
  Layout	
  Mode	
  
CTRL - or ⌘ - Insert	
  Current	
  Date	
  
CTRL + SHIFT + D 
or ⌘ +SHIFT+ D 

Manage	
  a	
  Database	
  

TAB Move	
  to	
  the	
  next	
  field	
  
SHIFT + TAB Move	
  to	
  the	
  previous	
  field	
  
CTRL + ê  Move	
  to	
  the	
  next	
  record	
  
CTRL + é  Move	
  to	
  the	
  previous	
  record	
  
CTRL + TAB or 
Option + TAB 

Puts	
  a	
  TAB	
  character	
  within	
  a	
  field.	
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between people and meetings, as a person can attend more than one meeting, and a meeting can have 
multiple attendees. The join table that resolves the many-to-many relationship is called Participant.

The goal of the following example is to create a script that sends an email with a PDF attachment (of a 
personalized agenda) to each participant in a meeting. In addition to the concepts introduced in this 
lesson, you will need to be familiar with material covered in Lessons 6.1 through 6.6, including conditional 
branching, error trapping, and use of the Go to Related Record (GTRR) script step.

Example 6.7.2
Open the file 06a_FTS_Meetings.fp7.

Open the 1. Manage Scripts dialog and create a new script named “Email_Agendas”.

Begin the script with the following error trap, which tests to see if the current meeting does not have2.
any participants:

If [ Count ( meeting_PARTICPANT::__kp_Participant ) = 0 ]

Show Custom Dialog [“Error”; “There are no participants for the 
current meeting.”]

Halt Script

End If

Add a 3. GTRR step that jumps to the set of participants for the current meeting. The settings for the
GTRR are shown in Figure 6.7.3. Opening a new window to work with the related records is not strictly
necessary, but it is a common practice to use a window like this as a temporary workspace. The user
never needs to see or interact with the new window, so its size and position are not crucial. You can
even make it 1 pixel tall and 1 pixel wide, or use a negative number as the left or top setting to position
it outside the visible workspace. At the end of the script, the window will be closed, leaving the user’s
original window context completely unaltered.

Figure 6.7.3

Set up the outline of a routine to loop through the set of 4. Participant records by adding the following
steps to the script. For now, you can see that a comment has been added where the PDF generation
and email will be added. Note also that while the Go to Record/Request/Page [First] step is not
necessary (the GTRR will leave you on the first record), it is included here as extra insurance. There is
no harm to include it; and should you ever alter the routine, it could avoid issues.
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Go to Record/Request/Page [First]

Loop

# this is where the PDF generation and email will happen

Go to Record/Request/Page [Next; Exit after last]

End Loop

Within the loop, in the space where the comment is, add a 5. Set Variable step to create a variable as
the file path for a PDF of the personalized meeting agenda. For the purpose of this exercise, use the
participant’s full name as the file name.

Set Variable [$fileName; Value: “file:” & Get (DesktopPath) & 
participant_PERSON::NameLastFirst & “.pdf”]

Similarly to Example 6.7.1, add a 6. Save Records as PDF script step for writing out the current record as
a PDF file, using a file path/name determined by the $fileName variable.

Add a 7. Send Mail step to the script. The options to use are shown in Figure 6.7.4. Notice at the bottom
of the dialog that you can specify a file attachment for the email. Use the same $fileName variable to
reference the PDF created in the previous step.

Figure 6.7.4

A new Send Mail option in FileMaker Pro 10 is the ability to send email via an SMTP Server. 
Previously, the only option was to utilize the email client of the user. Figure 6.7.5 shows the SMTP 
Options dialog. Configure this as you would the settings for an email account. If you do not have SMTP 
configuration options at hand, choose E-mail Client as the Send via: option.
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Figure 6.7.5

Beneath the 8. End Loop step, insert a Close Window [Current Window] step into the script. As
mentioned previously, this will close the window opened up by the Go to Related Record step,
thereby returning users to their original window context.

Save and exit the script and close the 9. Manage Scripts dialog.

Navigate to the 10. Meeting_Detail layout, enter Layout mode, and add a button to the layout that
triggers the Email_Agendas script. Test and debug the script until it works as expected.

Additional Tips

Delete files using Export Field Contents
In a script routine like that in Example 6.7.2, you will end up with a lot of documents strewn on the user’s 
workstation. Files can in fact be deleted using the Export Field Contents script step. That step is typically 
intended to output the contents of a single field from a single record, such as when you want to retrieve 
the contents of a container field. However, if you specify a file path/name for output (either explicitly or by 
a variable reference) and do not select a field to export, that file, if it exists, will be deleted from the user’s 
workstation. An error code is returned (102, Field is missing), but you may disregard it.

In Example 6.7.2, by adding the following script step after the Send Mail step, you can “clean up” after 
yourself by removing the PDF email attachment.

Export Field Contents [“$fileName”]
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Email_Agendas

#

If [ Count (meeting_PARTICIPANT::__kp_Participant ) = 0 ]

Show Custom Dialog [ Title: "Error"; Message: "There are no participants for the current meeting."; Buttons: “OK” ]

Halt Script

End If

#

Go to Related Record [ From table: “meeting_PARTICIPANT”; Using layout: “Participant_Agenda” (PARTICIPANT) ]
[ Show only related records; New window ]

#

Go to Record/Request/Page
[ First ]

Loop

Set Variable [ $fileName; Value:"file:" & Get (DesktopPath) & participant_PERSON::NameLastFirst & ".pdf" ]

Save Records as PDF [ File Name: “$filename”; Current record ]
[ Document - Compatibility: Acrobat 5 and later ]
[ Pages - Number Pages From: 1; Include: All pages ]
[ Security - Printing: High Resolution; Editing: Any except extracting pages; Enable copying; Enable Screen Reader ]
[ Initial View - Show: Pages Panel and Page; Page Layout: Single Page; Magnification: 100% ]

[ Restore; No dialog ]

Send Mail [ Send via E-mail Client; To: participant_PERSON::Email; Subject: "Meeting Agenda: " & participant_MEETING::Title; Message:
"Please find attached the agenda for the upcoming meeting."; Attachment: “$fileName” ]

Go to Record/Request/Page
[ Next; Exit after last ]

End Loop

#

Close Window [ Current Window ]

August 29, 2012 9:10:50 -1-06a_FTS_Meetings_Solution.fp7 - Email_Agendas
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Search

FileMaker  9 Tip#1: H iding Something on the Layou t

7-10-2007 by Geoff Coffey

One of the most exciting new features in FileMaker 9 is Conditional Formatting. I think this is awesome because
now you can apply dynamic custom styles to layout elements without adding dozens of crufty unstored calcs to your
table. When I first started playing with conditional formatting, though, I felt a little let down by one thing: There’s
apparently no way to make something disappear  using conditional formatting. I often have the need to show
something to my user — an informational message, indicator icon, or even a button — only under certain
conditions. It turns out that with some creative thinking, you can show and hide layout elements with
conditional formatting. (Some restrictions apply.)

This is actually two techniques in one. The solution is simple if you’re only trying to hide some text. If you have a
graphic, button, or collection of objects to hide, on the other hand, you’ll use a different method.

Making Text Disappear

To make some text disappear — an informational label by a field, or a warning message that doesn’t apply, for
example — simply change the text color to match the background color. For example, suppose you have a
database that looks like this:

You want the little “[required]” label next to a field to disappear when your user enters something in the field. This is
a breeze:

1. Select the text label and choose Format -> Conditional.
The Conditional Formatting for selected objects dialog box appears.

2. Click Add.
FileMaker adds a new line to the Condition list. In other words, you’re establishing a condition under which
you want special formatting applied to this object.
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3. Click Specify and enter this calculation: not IsEmpty(Customers::First Name) in the Specify
Calculation window.
In this case, you want to format the label when the First Name field is not empty. When the formula you
entered evaluates to a true value, the formatting will be applied.

4. Click OK to close the Specify Calculation dialog box.
Now you need to tell FileMaker what kind of formatting to apply.

5. Turn on the Text Color check box and pick an appropriate color from the rainbow-colored pop-up
menu beside it.
Choose a color that matches your background color exactly. In the picture above, the background is
FileMaker’s lighest gray color, so I picked that color here.

When you’re finished with these steps, click OK in the Conditional Formatting window and switch to Browse
mode. Now as you enter information in the fields on the layout, the “[required]” reminders will disappear like magic:

Note: You could also make the text invisible on the layout, then use conditional formatting to make the
object appear (by applying a visible color) when you want it to show. This might make the condition
formula a little more obvious because it is expressed positively instead of negatively. But having
invisible items on the layout is a nuisance. If you find it easier to write a formula saying when the text
should appear, do that. Then put not in front of it. It’s that easy.

Making Other  Things Disappear

The technique above has a pretty serious limitation: it only works with a single text object. If you’re dealing with a
graphic (perhaps it is an icon that marks each unpaid invoice) or some other object, you’re not going to make it
disappear by turning it white. In fact, if you select most kinds of layout objects, the Format -> Conditional menu
command dims: FileMaker can only apply conditional formatting to text objects, fields, buttons, and web viewers.

To work around this limitation, you have to get a little creative: Use an empty text object:

1. Using the Text tool in Layout mode, create a new text object (by clicking somewhere on the
layout) and type a single space. Then click outside it so it’s no longer expecting input.
You now have a (mostly) empty text object that you can resize and position as you see fit. (You need the
space because FileMaker will automatically delete the text object if you make it completely empty.)

2. Position this text object over the element or elements you want to hide.
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You may need to resize it so it covers the item completely. Also, make sure it is in front of the item it is
hiding (use Arrange -> Bring to Front if necessary).

3. Choose Format -> Conditional and apply conditional formatting just like you did in the previous
example.
This time, though, turn on the Fill Color check box instead of Text Color. You should still choose a color that
matches the background.

When you’re finished, switch to Browse mode and give it a try. When your formatting condition is met, everything
under the text object will disappear.

Dealing with Buttons

The first gotcha with this technique is that although you hide an item from view, you don’t hide it from the mouse. If
the thing you’re covering up is a button, it will still be clickable even when hidden. Luckily, this is easy to fix: Just
modify the button’s script so it does nothing when the button is hidden. Add a snippet of code like this to the top of
your script:

 If [ IsEmpty(Customer::Email Address) ]
    Exit Script

 End If

The formula in the If step should match the one you used in the Conditional Formatting dialog box exactly. Now,
although the button is clickable, it won’t do anything. And since you can’t see it, you won’t be inclined to click it
anyway. Problem solved.

Other  Limitations

Buttons aren’t the only layout objects that present a challenge. Fields can also be entered even when hidden. In
fact, fields are even worse: You can tab into them without clicking at all. They show dotted field frame outlines
when you click in a blank spot on the layout. And they sometimes show their information right over the top of your
carefully placed coverup. In general, this technique is not suitable for hiding fields. Same goes for Tab controls and
Web Viewers.

Finally, sometimes the color behind the thing you’re trying to hide is not consistent. The most typical example is a
portal with alternating background colors. In a case like this, there’s no straight forward way to decide what color
the empty text object should take on when it comes time to hide.

These limitations aside, this technique provides a simple way to add more dynamic behavior to your user interfaces
without complicating the underlying data model. That’s almost always a win in my book.

Trackback URL

18 Comments

1. Jesse Barnum
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Highlight the active field with conditional
formatting
by Chad Novotny on Mar 11, 2010, filed under: Tips & Tricks, Advanced Techniques, Downloads

This is one of my favorite tips, which we first published in August 2007 when conditional formatting was
introduced in FileMaker Pro 9.  A not-uncommon request we’ve received over the years is to highlight the
current field with something more than slightly darker field borders.  Conditional formatting seems the perfect
answer: there must be a way to change a field’s background fill from its default to another color on entering the
field, right?

Turns out… no.  You cannot use conditional formatting to change a field’s fill color on entering it.  It’s just not
possible.  Never.  Conditional formatting does not work in any way whatsoev er while focus is in the
field in question. And that’s when the epiphany struck.

Instead of trying to change a field’s fill from the default to another color on gaining focus, make the default color
of every field the color it should have on entry.  Yes, that’s right, if you want fields to turn yellow when a user
tabs to the field, make them ALL yellow in Layout mode.  Now, use conditional formatting to change their color
when they do not have focus.  Select all your fields, and apply the following conditional formatting rule: set the
fill color to white under the condition “Formula is…”

True

That’s it (and how’s that for a complicated calculation formula?).  Now, whenever the field does not have focus,
the conditional formatting is tested, the formula will evaluate as true (of course), and the unfocused field will
have its “default” white fill.  On entering the field, the conditional formatting disappears and the field turns
yellow.

Log in or register to download the sample file.

Ed Roseman
05/10/2010

Very cool and ingenious. Thanks.

But I’m scratching my head trying to figure out what the “True” is “truing”
about. WHAT is true? I’m sure this is a contracted paraphrase of some
other command or logic, but what is it?

Chad Nov otny
05/11/2010

Thanks, Ed.

Conditional formatting uses a logical test, such as “salary < 50,000”, or
“Self < Get ( CurrentDate )”, to decide when to apply the formatting. 
Each of these tests can result in either true or false.  But True is always,
well, true: the formatting is always applied.  You could think of it as “1 =
1”; that’s always going to be true.

An even shorter way of writing “True” is the just the number “1”.  In fact, if
you have a formula that’s evaluates the word True (NOT in quotes, so as
not to treat it as a string), you get the number 1.  I just like to say True
instead to be clear I’m talking about a logical value instead of a number;
it’s the way my mind works.

Jim Liston
06/28/2010

Most excellent tip. Now, how about highlighting the whole record on
focus. When in a list view, the only way to tell which record is being
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